18 Січень 2014
1 381
Рубрика: код

Как заставить работать Callme и Buyme со старыми версиями jQuery

Основная инструкция, как заставить работать скрипты, если ваш jQuery версии 1.6.9 и ранее.

Некоторые админы не могут или не хотят обновлять версии jQuery до свежих релизов. Бывает, что старые версии слайдеров или других скриптов могут работать только с версиями до 1.6. А эта версия вышла 2009-м году.

Хоть в большинстве случаев нежелание обновляться связано просто с ленью админа, в результате Callme или Buyme не запускаются. Виноват в этом конечно же — я :).

Почему так? Мои скрипты грузятся динамически, не мешая загрузке основного контента. А функции динамической загрузки были переработаны в версии jQuery 1.7. Если кому интересно, подробнее я описал на форуме. Для тех, кто не может или не хочет обновляться до более свежих версий, я подготовил и давно предложил скачивать даунгрейды для старых версий jq.

Хочу напомнить: если у вас jQuery версии от 1.4 до 1.6.9 включительно, то для работоспособности Callme и Buyme вам нужно обновить основной файл скрипта. Этот файл называется js/callme.js и js/buyme.js соответственно.

Где взять?

Все просто: ссылка для обоих файлов всегда одинакова. Если я обновляю какие-то функции, то автоматически обновляется и сам файл, а его адрес не меняется. Чтобы вы не путались, в комментариях в самом верху файла есть его дата обновления.

// jQuery.Callme 1.9.5: author Nazar Tokar * nazarTokar.com * dedushka.org * Copyright 2010
// jQuery.Storage: author Dave Schindler * Distributed under the MIT License * Copyright 2010
// for using with jquery from 1.4 to 1.6.9
// updated on 2014-01-18

Скачать файлы можно отсюда:

Протестировано с jQuery 1.6.1.

Тепер я хочу бачити коментарі 5